Description
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
- Line 1: Two space-separated integers: N and M
- Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
- Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23
题目大意
题目背景是一个女人买手镯,第一行是两个数N,M分别表示N个手镯和最大重量。
接下来的N行表示每一个手镯的魅力值和重量,要求在重量不超过最大重量的情况下使得买的手镯的魅力值总和最大。
思路
01背包问题,背包上限为最大重量M。
代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=12880+5;
int dp[maxn],n,m,v[maxn],w[maxn];
int main()
{
while(~scanf("%d %d",&n,&m))
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
scanf("%d %d",&w[i],&v[i]);
}
int temp=-99999999;
for(int i=1;i<=n;i++)
{
for(int j=m;j-w[i]>=0;j--)
{
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
if(dp[j]>temp) temp=dp[j];
}
}
printf("%d\n",temp);
}
}