【HDU 2717】Catch That Cow(BFS)

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目大意

给你两个数N和K,每一分钟可以进行一种操作,操作包括以下三种:
假设当前的数为X:
①X=X+1;
②X=X-1;
③X=X*2;
问你从N开始经上述三种操作最短几分钟可以将N变为K。

思路

结合BFS的原理,只需要将这三种操作都进行BFS,第一个满足条件的过程所花费的分钟数一定是最短的。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;
const int maxn=100010;
int vis[maxn],n,k;

int is(int x)
{
    if(x<0 || x>=maxn || vis[x])  
        return 0;  
    return 1;
}

struct proc
{
    int x,step;
};

int bfs(int s)
{
    queue<proc> q;
    proc vw,vn;
    vw.x=s;
    vw.step=0;
    vis[s]=1;
    q.push(vw);
    while(!q.empty())
    {
        vw=q.front();
        q.pop();
        if(vw.x == k) 
        {
            return vw.step;
        }
        vn=vw;
        vn.x=vw.x+1;
        if(is(vn.x))
        {
            vn.step=vw.step+1;
            vis[vn.x]=1;
            q.push(vn); 
        }
        vn.x=vw.x-1;
        if(is(vn.x))
        {
            vn.step=vw.step+1;
            vis[vn.x]=1;
            q.push(vn);
        }
        vn.x=vw.x*2;
        if(is(vn.x))
        {
            vn.step=vw.step+1;
            vis[vn.x]=1;
            q.push(vn);
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d %d",&n,&k))
    {
        memset(vis,0,sizeof(vis));
        int ans=bfs(n);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值