num.3 Catch That Cow POJ - 3278

题目:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:

有一个农民和一头牛,他们在一个数轴上,牛在k位置保持不动,农户开始时在n位置。设农户当前在M位置,每次移动时有三种选择:1.移动到M-1;2.移动到M+1位置;3.移动到M*2的位置。问最少移动多少次可以移动到牛所在的位置。
所以可以用广搜来搜索这三个状态,直到搜索到牛所在的位置。其实也是道·板子题

#include<iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include<queue>
#define MAX 100001
using namespace std;
queue<int> q;//使用前需定义一个queue变量,且定义时已经初始化
bool arr[MAX];//访问空间
int step[MAX];       //记录步数的数组不能少
bool bound(int num)//定义边界函数
{
       if(num<0||num>100000)
                return true;
       return false;
}
int BFS(int st,int end)
{
         queue<int> q;//使用前需定义一个queue变量,且定义时已经初始化
         int t,temp;
         q.push(st);//进队列
         arr[st]=true;
         while(!q.empty())//重复使用时,用这个初始化
            {
                t=q.front();//得到队首的值
                q.pop();//出队列,弹出队列的第一个元素,并不会返回元素的值
                for(int i=0;i<3;++i) //三个方向搜索
                {
                     if(i==0)
                        temp=t+1;
                     else if(i==1)
                        temp=t-1;
                     else
                        temp=t*2;
                     if(bound(temp))         //越界
                        continue;
                     if(!arr[temp])//访问空间未被标记
                        {
                             step[temp]=step[t]+1;
                     if(temp==end)
                        return step[temp];
                     arr[temp]=true;//标记此点
                     q.push(temp);//将temp元素接到队列的末端;
                     }
                }
            }
}
int main()
{
    int st,end;
    while(scanf("%d%d",&st,&end)!=EOF)
        {
             memset(arr,false,sizeof(arr));//arr数组进行初始化操作
             if(st>=end)
                cout<<st-end<<endl;
             else
                cout<<BFS(st,end)<<endl;
        }
    return 0;
}

BFS算法:

思路:

1.从初始状态S开始,利用规则,生成下一层的状态。

2.顺序检查下一层的所有状态,看是否出现目标状态G。

否则就对该层所有状态节点,分别利用规则。生成再下一层的所有状态节点。

3.继续按照上面思想生成下一层的所有状态节点,这样一层一层往下展开。

直到出现目标状态为止

Ps

因为对结构体不是很熟悉,所以在这次就定义了有参的bfs函数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值