【HDU 1025】Constructing Roads In JGShining's Kingdom(最长上升子序列LIS)

Description

JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

这里写图片描述

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint

Huge input, scanf is recommended.

题目大意

有两种城市,富有(并不是有钱,而是有一种富有的资源,用一个数字N标记其富有的资源)和贫穷(并不是没钱,而是缺乏一种资源,用一个数字N标记其缺乏的资源)城市,富有城市的非常希望贫穷城市能够从富有城市进口他们所要的资源,所以决定在富有城市和贫穷城市之间修建道路,但是只有贫穷城市缺乏的资源刚好是富有城市富有资源之间的城市才能建立道路,并且道路不能出现交叉的现象。问你最多能修建几条道路。

思路

为了保证道路之间不会出现交叉同时修建的道路数又要最多,那么我们从下面开始分析:
①什么时候会出现道路交叉:如下图所示:
这里写图片描述
②怎样才能连接更多的道路:如下图所示:
这里写图片描述
从上图我们可以发现只要保证一边有序,只要求出另一边的最长连续子序列就可以连接最多的道路,因为不存在a[i]小于b[i]的情况出现,自然也就不存在交叉的问题。对于求最长连续子序列问题可以用LIS(nlogn)算法。
LIS算法可以见:
http://blog.csdn.net/shuangde800/article/details/7474903
http://blog.csdn.net/sdjzping/article/details/8759870

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn=500000+5;

int n,pr[maxn],stack[maxn],len;

int main()
{
    int p,r,caseTime=1;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d",&p,&r);
            pr[p]=r;
        }
        stack[1]=pr[1];
        len=1;
        for(int i=2;i<=n;i++)
        {
            if(stack[len]<pr[i])
            {
                stack[++len]=pr[i];
            }
            else
            {
            int tmp=lower_bound(stack,stack+len,pr[i])-stack;
            stack[tmp]=pr[i];
            }
        }
    printf("Case %d:\n",caseTime++);
    if(len==1) printf("My king, at most 1 road can be built.\n\n");
    else printf("My king, at most %d roads can be built.\n\n",len);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值