【POJ 3126】Prime Path(枚举+BFS)

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题目大意

题目大概就是给你两个四位的素数sta,pos,问你sta最少经几步的变换可以变到pos,每次变换只能修改四位数中某一位数,并且变换完这位数后必须保证变换后的sta必须还是素数。

思路

枚举四位数的个位,十位,百位和千位。对于个位可以做剪枝操作,因为要保证四位数为素数,那么个位必定不能为偶数。对于十位和百位,共有10种变换(0~9),千位只有9种变换(1~9),因为千位不能为0,因为是四位数。bfs操作第一个找到的所需的步数最少。
素数判定需要注意,判断一个数是否是素数,只需要循环到根号这个数就可以了,不需要循环到这个数。
具体实现看代码

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;
const int maxn=105;

int vis[15000];
int sta,pos;

struct proc
{
    int x,step;
};

bool isLeagal(int x)//判断素数
{
    if(x==2&&x==3) return true;
    else if(x<=1||x%2==0) return false;
    else if(x>3)
    {
        for(int i=3;i*i<=x;i++)
        {
            if(x%i==0) return false;
        } 
        return true;
    }
}

int bfs(int s)
{
    proc vw,vn;
    queue<proc> q;
    vw.x=s;
    vw.step=0;
    vis[s]=0;
    q.push(vw);
    while(!q.empty())
    {
        vw=q.front();
        q.pop();
        if(vw.x==pos)
        {
            return vw.step;
        }
        int tmpx=vw.x%10;//获取x的个位 
        int tmpy=(vw.x/10)%10;//获取x的十位 
        for(int i=1;i<=9;i+=2)//枚举个位 
        {
            vn.x=(vw.x/10)*10+i;
            if(vn.x!=vw.x&&!vis[vn.x]&&isLeagal(vn.x))
            {
                vis[vn.x]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        } 
        for(int i=0;i<=9;i++)//枚举十位 
        {
            vn.x=(vw.x/100)*100+i*10+tmpx;
            if(vn.x!=vw.x&&!vis[vn.x]&&isLeagal(vn.x))
            {
                vis[vn.x]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        }
        for(int i=0;i<=9;i++)//枚举百位 
        {
            vn.x=(vw.x/1000)*1000+i*100+tmpy*10+tmpx;
            if(vn.x!=vw.x&&!vis[vn.x]&&isLeagal(vn.x))
            {
                vis[vn.x]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        }
        for(int i=1;i<=9;i++)//枚举千位 
        {
            vn.x=(vw.x%1000)+i*1000;
            if(vn.x!=vw.x&&!vis[vn.x]&&isLeagal(vn.x))
            {
                vis[vn.x]=1;
                vn.step=vw.step+1;
                q.push(vn);
            }
        }
    }
    return -1;      
}

int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d %d",&sta,&pos);
        int ans=bfs(sta);
        if(ans!=-1) printf("%d\n",ans);
        else printf("Impossible\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值