PAT甲级1001 A+B Format

题目:

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

解析:

计算a+b,并将结果以标准形式输出,即每三位用逗号间隔开。

答案:

#include<stdio.h>
#include<iostream>

using namespace std;

int main()
{
    int a,b;
    cin>>a>>b;
    
    int result=a+b;
    //题目已给定数据范围,直接加不会溢出
    
    if(result<0)
    {
        cout<<"-";
        result=-result;
    }//先考虑是不是负数
    else if(result==0)
    {
        cout<<0;
        return 0;
    }//0
    
    int i,part[7];
    for(i=0;result>0;i++)
    {
        part[i]=result%10;
        result=result/10;
    }//将数字按位分开
    
    for(int j=i-1;j>=0;j--)
    {
        cout<<part[j];
        if(j%3==0&&j!=0)
        {
            cout<<",";
        }每三位输出一个逗号,个位之后不要逗号
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值