PAT甲级 1001 A+B Format

113 篇文章 9 订阅
110 篇文章 12 订阅

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

代码编写如下:

#include<iostream>
#include<stack> 
using namespace std;


int main(){
	
	int a,b;
	cin>>a;
	cin>>b;
	
	int sum = a+b;
	if(sum == 0){
		cout<<"0"<<endl;
	}
		
	if(sum < 0)
	{
		cout<<"-";
		sum *= -1;
	}
	
	stack<int> myStack;

	while(sum > 0)
	{
		myStack.push(sum%10);
		sum/=10;
	}
	
	while(!myStack.empty()){
		cout<<myStack.top();
		myStack.pop();
		if(myStack.size() % 3 == 0 && !myStack.empty()){//不能最后一个是逗号,并且从右向左每三个数一个逗号 
			cout<<",";
		}			
	} 
	return 0;
} 

简洁版:

#include<iostream>
#include<string>
using namespace std;


int main(){
	int a,b;
	cin>>a;
	cin>>b;
	string s = to_string(a+b);
	
	for(int i = 0;i < s.size();i++){
		cout<<s[i];
		if(s[i] !='-')
		{
			if( (s.size() -1 - i)%3 == 0 && i!=(s.size()-1) )//注意,是打印该数字后,除了该数字外剩余的数是3的整数倍
				cout<<",";
		}
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值