PAT甲级1001A+B Format

题目:

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 题意:计算a+b,结果每三个数字用一个逗号分隔

思路:因为a,b都在int范围之内,所以先计算出结果再转化成字符串操作,要注意从后开始操作,防止最后不足三位也有逗号

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    int a,b;
    cin>>a>>b;
    int c=a+b;
    string s=to_string(c),ans;
    if(s[0]=='-')
    {
        cout<<'-';
        s.erase(s.begin());
    }
    int cnt=0;//每三个数字用一个逗号分隔
    for(int i=s.length()-1;i>=0;--i)
    {
        ans+=s[i];
        ++cnt;
        if(cnt==3 && i!=0)
        {
            ans+=',';
            cnt=0;
        }
    }
    reverse(ans.begin(),ans.end());
    cout<<ans;
    system("pause");      
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值