POJ-1734 Sightseeing trip (无向图最小环[Floyd])

Sightseeing trip
http://poj.org/problem?id=1734
Time Limit: 1000MS Memory Limit: 65536K
    Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2


题目大意:给一个有重边无自环的无向图,输出最小环的路径

依旧按照无向图最小环的floyd算法求,由于要输出路径,所以更新最短路时也要更新路径

开始只用了pre数组输出答案,一直WA,发现后来的最短路会更改pre数组,所以每次更新最小环时也要更新最小环的路径


#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,m,ans,num,des;
int dis[105][105],g[105][105],pre[105][105],path[105];//path记录答案路径

void floyd() {
    ans=0x1f1f1f1f;
    for(int k=1;k<=n;++k) {
        for(int i=1;i<k;++i)
            for(int j=i+1;j<k;++j)
                if(dis[i][j]+g[i][k]+g[k][j]<ans) {
                    ans=dis[i][j]+g[i][k]+g[k][j];
                    num=0;
                    path[num++]=k;//更新最小环的路径
                    des=j;
                    while(i!=des) {
                        path[num++]=des;
                        des=pre[i][des];
                    }
                    path[num++]=i;
                }

        for(int i=1;i<=n;++i)
            for(int j=1;j<=n;++j)
                if(dis[i][j]>dis[i][k]+dis[k][j]) {
                    dis[i][j]=dis[i][k]+dis[k][j];//更新货币i到货币j的最大汇率
                    pre[i][j]=pre[k][j];
                }
    }
}

int main() {
    int s,e,w;
    while(scanf("%d%d",&n,&m)==2) {
        for(int i=1;i<=n;++i)
            for(int j=1;j<=n;++j) {
                pre[i][j]=i;//pre[i][j]表示i到j的最短路中倒数第2个点
                g[i][j]=dis[i][j]=0x1f1f1f1f;
            }
        while(m-->0) {
            scanf("%d%d%d",&s,&e,&w);
            if(w<g[s][e])
                dis[s][e]=dis[e][s]=g[s][e]=g[e][s]=w;
        }
        floyd();
        if(ans==0x1f1f1f1f)
            printf("No solution.\n");
        else
            while(num-->0)
                printf("%d%c",path[num],num==0?'\n':' ');
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值