ZOJ-3329 One Person Game (概率DP)

3 篇文章 0 订阅

One Person Game

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

题目大意:有三个分别有k1,k2,k3面的骰子,计数器初始为0,每次加上三个骰子点数和,若k1==a&&k2==b&&k3==c,则计数器清零,求最终点数超过n的掷骰子次数的期望?


设dp[i]表示点数i离目标状态还需掷骰子次数的期望

状态转移方程很好想:dp[i]=∑(p[k]*dp[i+k])+1/(k1*k2*k3)*dp[0]+1;                                                                ①

但是由于存在dp[0],所以没法直接使用

刚开始我用dp[i]-dp[i+1]求出一个方程,然而右边常数项没了,就没法进行转移。。。

看了题解后才发现:由于dp[i]与dp[0]都有线性关系,所以可以设系数a[i],b[i],令dp[i]=a[i]*dp[0]+b[i];      ②

将②式带入①式右边可得:dp[i]=∑(p[k]*(a[i+k]*dp[0]+b[i+k]))+1/(k1*k2*k3)*dp[0]+1;

整理可得:dp[i]=∑(p[k]*a[i+k]+1/(k1*k2*k3))*dp[0]+∑(p[k]*b[i+k])+1;                                                             ③

对比②③右边可得:

a[i]=∑(p[k]*a[i+k]+1/(k1*k2*k3));

b[i]=∑(p[k]*b[i+k])+1;

【上述各式中:3<=k&&k<=k1*k2*k3】

而dp[0]=a[0]*dp[0]+b[0] 可以推出:dp[0]=b[0]/(1-a[0]);

所以可以先推出a[0]和b[0],再求出dp[0];

感觉概率dp就是数列求能够直接递推的递推公式

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,k1,k2,k3,x,y,z;
double a[625],b[625],p[225],sum;

int main() {
    int T;
    scanf("%d",&T);
    while(T-->0) {
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&x,&y,&z);
        memset(p,0,sizeof(p));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=1;i<=k1;++i) {
            for(int j=1;j<=k2;++j) {
                for(int k=1;k<=k3;++k) {
                    p[i+j+k]+=1;
                }
            }
        }
        sum=k1*k2*k3;
        p[0]=1;
        p[x+y+z]-=1;
        for(int i=sum;i>=0;--i) {
            p[i]/=sum;
        }
        for(int i=n;i>=0;--i) {
            a[i]=p[0];
            b[i]=1;
            for(int k=3;k<=sum;++k) {
                a[i]+=p[k]*a[i+k];
                b[i]+=p[k]*b[i+k];
            }
        }
        printf("%.15lf\n",b[0]/(1-a[0]));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值