POJ-2234 Matches Game(尼姆博弈)

题目链接

POJ-2234 Matches Game

题目大意

n 堆石子,每次可以从任意一堆拿任意数量的石子,至少拿1个,两人轮流进行,问先手是否必胜?

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

思路

直接是:尼姆博弈。
好多都只是给出结果,并没有给出尼姆博弈为什么可以使用异或运算。
这个解释证明了异或和为 0 <script type="math/tex" id="MathJax-Element-1">0</script>是必败点。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,ans,a;

int main() {
    while(scanf("%d",&n)==1) {
        ans=0;
        while(n-->0) {
            scanf("%d",&a);
            ans^=a;
        }
        printf("%s\n",ans==0?"No":"Yes");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值