【杭电1061】Rightmost Digit 求n^n,找规律!!

 Rightmost Digit
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the most right digit of N^N. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

Output

For each test case, you should output the rightmost digit of N^N. 
 

Sample Input

     
     
2 3 4
 

Sample Output

     
     
7 6

Hint

 In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6. 
         
 
   
刚开始按传统方法,总是超时。。。不能暴力解决  比较大的不能用pow,结果为浮点型,精度不准确,只能保证前11位正确
超时代码:
#include<stdio.h>
int f(int b)
{
	int i,t=1;
	for(i=1;i<=b;i++)
	t=t*b;
	return t;
}
int main()
{
	int a,n;
	int t;
	while(scanf("%d",&n)!=EOF)
	{
		while(n--)
		{
			scanf("%d",&a);
			t=f(a)%10;
			printf("%d\n",t);
		}
	}
	return 0;
}
正确代码(参考代码):
可以发现一个规律:
当   n = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 27 28 29 30 31 ...
rdigit = 1 4 7 6 5 6 3 6 9   0   1   6  3   6   5   6   7   4  9  0  1   4   7   6   5   6   3   6  9   0    ...
所以是以20为周期的规律。这样就简单多了。。
    
    
1
2
3
4
5
6
7
8
9
10
11
12
13
#include<stdio.h> 
  int  t[22]={0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
  int main ()
  {
      int m,n; 
      scanf("%d",&m) ;
      while(m--)
      {
        scanf("%d",&n);
        printf("%d\n",t[n%20]) ;
     }
     return 0 ;
 }

下面是 m^n  % k 的快速幂:模板
// m^n % k
int quickpow(int m,int n,int k)
{
    int b = 1;
    while (n > 0)
    {
          if (n & 1)
             b = (b*m)%k;
          n = n >> 1 ;
          m = (m*m)%k;
    }
    return b;
下面是套用的模板,在杭电上提交不知道为啥是wrong answer请高手指点!!\(^o^)/~
#include<stdio.h>
int quickpow(int m,int n,int k)
{
    int b = 1%k;
    while (n > 0)
    {
          if (n & 1)
             b = (b*m)%k;
          n = n >> 1 ;
          m = (m*m)%k;
    }
    return b;
} 
int main()
{
	int a,t,n;
	scanf("%d",&n);
		while(n--)
		{
			scanf("%d",&a);
			t=quickpow(a,a,10);
			printf("%d\n",t);
		}
return 0;	
}
下面也是套用模板,刚开始wrong answer why!!原来没有先对n,m取余,找了好久错误,哎。。。
#include<cstdio>
int quickpow(int n,int m,int mod)
{
	int b=1%mod,t=n%mod;n,m较大要先取余
	while(m)
	{
		if(m&1)
		{
			b=(t*b)%mod;//2^10=2^8*2^2=((2^2)^2)^2*2^2;不断开出2;

		}
		base=(t*t)%mod;
		m>>=1;//右移一位,相当于除以2;
		
	}
	return b;
}


int main()
{
	int a,n;
	scanf("%d",&n);
	while(n--)
	{	
	scanf("%d",&a);
		printf("%d\n",quickpow(a,a,10));
	}
	return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值