数字对称

E - E 圆周率用acos(-1.0) 使用longlong
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

A palindromic number or numeral palindrome is a 'symmetrical' number like 16461, that remains the same when its digits are reversed. In this problem you will be given an integer, you have to say whether the number is a palindromic number or not.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case starts with a line containing an integer n (0 ≤ n < 109).

Output

For each case, print the case number and 'Yes' if n is palindromic, otherwise print 'No'.

Sample Input

5

1

21

16161

523125

0

Sample Output

Case 1: Yes

Case 2: No

Case 3: Yes

Case 4: No

Case 5: Yes

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[100];
int main()
{ 
int t,k=1;
scanf("%d",&t);
while(t--)
{
	int n;
	scanf("%d",&n);
	int s=0;
	while(n)
	{
		int t=n%10;
		num[s++]=t;
		n=n/10;
	}
	int faut=0;
	for(int i=0;i<s;i++)
	{
		if(num[i]!=num[s-1-i])
		{
			faut=1;
			break;
		}
	}
	printf("Case %d: ",k++);
	if(faut==1)
	printf("No\n");
		else
	   printf("Yes\n");
}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值