A+B for Matrices

题目1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:19925

解决:7958

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题
题意:输入两个数组,计算两个数组对应行列和为0的个数


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
     int n,m;
     int hang1[110],lie1[110],a[110][110],hang2[110],lie2[110],b[110][110];
     while (~ scanf ( "%d" ,&m),m)
     {
         scanf ( "%d" ,&n);
         memset (lie1,0, sizeof (lie1));
     memset (hang1,0, sizeof (hang1));
     
         for ( int i=1;i<=m;i++)
         for ( int j=1;j<=n;j++)
         scanf ( "%d" ,&a[i][j]);
     for ( int i=1;i<=m;i++)
     {
         for ( int j=1;j<=n;j++)
         {
             hang1[i]=hang1[i]+a[i][j];
         lie1[j]=lie1[j]+a[i][j];
         }
     }
    memset (hang2,0, sizeof (hang2));
     memset (lie2,0, sizeof (lie2));
         for ( int i=1;i<=m;i++)
         for ( int j=1;j<=n;j++)
         scanf ( "%d" ,&b[i][j]);
     for ( int i=1;i<=m;i++)
     {
         for ( int j=1;j<=n;j++)
         {
             hang2[i]=hang2[i]+b[i][j];
         lie2[j]=lie2[j]+b[i][j];
         }
     }
//  for(int i=1;i<=m;i++)
//  printf("%d ",hang2[i]);
     int sum1=0,sum2=0;
     for ( int i=1;i<=m;i++)
     {
         if (hang1[i]+hang2[i]==0)
         sum1++;
     }
     for ( int i=1;i<=n;i++)
     {
         if (lie1[i]+lie2[i]==0)
         sum2++;
     }
     printf ( "%d\n" ,sum1+sum2);
     }
     return 0;
  }
/**************************************************************
     Problem: 1001
     User: idealistic
     Language: C++
     Result: Accepted
     Time:0 ms
     Memory:1048 kb
****************************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值