武汉科技大学计算机学院菜鸟杯:Picture (杭电2052)

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11187    Accepted Submission(s): 5791


Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
  
  
3 2

Sample Output
+---+
|   |
|   |
+---+

 

 

代码如下:

#include<stdio.h>

int main()
{
    int i,j,n,m;
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        printf("+");
        for (i=1;i<=n;i++)
          printf("-");
        printf("+");
        printf("\n");
        for (i=1;i<=m;i++)
        {
            printf("|");
            for (j=1;j<=n;j++)
                printf(" ");
            printf("|\n");
        }
        printf("+");
        for (i=1;i<=n;i++)
          printf("-");
        printf("+\n");
        printf("\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值