HDOJ 2052 Picture(暑期练习)

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24490    Accepted Submission(s): 12452


Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
  
  
3 2
 

Sample Output
  
  
+---+ | | | | +---+
 

Author
xhd
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   2054  2072  2053  2055  2056 


思路:我感觉没什么思路,就是自定义函数,去年(NOW 2016年6月1日21:21:12 )没有做出来这个题。。。是不是很水昂。。。。

 

AC代码:

/*=============================AC情况===============================*/
/*题目网址:   */
/*时间: */
/*心得:  */

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define G 100

void hang(int w) {
	printf("+");
	for(int j=0; j<w; j++)
		printf("-");
	printf("+\n");
}

void jian(int w,int h) {
	for(int j=0; j<h; j++) {
		printf("|");
		for(int k=0; k<w; k++) {
			printf(" ");
		}
		printf("|\n");
	}
}

int main() {
	int w,h;
	while(scanf("%d%d",&w,&h)!=EOF) {
		hang(w);
		jian(w,h);
		hang(w);
		printf("\n");
	}
	return 0;
}

/*********************************测试数据*********************************


**************************************************************************/


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值