hdoj 1020 encoding

Encoding
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28368    Accepted Submission(s): 12567

 

Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.


 


Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.


 


Output

For each test case, output the encoded string in a line.


 


Sample Input

2
ABC
ABBCCC


 


Sample Output

ABC
A2B3C


 #include<stdio.h>
#include<string.h>
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        char ch[10010];
        int count=1,i,len;
        gets(ch);
        len=strlen(ch);
        for(i=0;i<len;i++)
        {
                if(ch[i]==ch[i+1])
                {
                    count++;
                    }
                    else
                    {
                        if(count==1)
                        printf("%c",ch[i]);
                        else
                        {
                        printf("%d%c",count,ch[i]);
                        count=1;
                            }               
                        }
            }
            printf("\n");
        }
    return 0;
    }
   
   

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值