PAT甲级--1014 Waiting in Line (30 分)【队列的使用】

21 篇文章 0 订阅

 

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

题意:就是有n个窗口,每个窗口以黄线为界,每个窗口有效即黄线内的人数是m,n*m+1个人在黄线外,哪个窗口人少排哪队,如果一样少就排号码小的,最早开始时间是8点,下午17点结束

 解题思路:用一个结构,记录每个窗口的队首完成的时间以及队尾完成的时间,先处理n*m个人,然后在处理>n*m个人,这里先将时间用分钟计算,有利于后面处理,每次都要判断这个窗口的队尾结束时间有没有超过540,如果超过这个点就做个标记表示要对他说sorry了,具体见代码

#include<bits/stdc++.h>
using namespace std;
struct Queue{
	int poptime,endtime;
	queue<int> q;
};
int main(void)
{
	int n,m,k,q,index=1;
	scanf("%d%d%d%d",&n,&m,&k,&q);
	vector<int>usetime(k+1);
	vector<int>result(k+1);
	vector<Queue>window(n+1);//结构数组
	vector<bool>sorry(k+1,false);//数组不小心弄成n了,导致最后一个测试点过不了
	for(int i=1;i<=k;i++) 
	scanf("%d",&usetime[i]);//每个人需要用的时间
    //将m*n的人处理
	for(int i = 1; i <= m; i++) {
        for(int j = 1; j <= n; j++) {
            if(index <= k) {
                window[j].q.push(usetime[index]);
                if(window[j].endtime >= 540)
                    sorry[index] = true;
                window[j].endtime += usetime[index];
                if(i == 1)
                    window[j].poptime = window[j].endtime;
                result[index] = window[j].endtime;
                index++;
            } 
        }
    }
 //   cout<<index<<endl;
    //处理>n*m的人
	while(index<=k)
	{
		//找出先完成的窗口
		int mintemp=window[1].poptime,minwindow=1;
		for(int i=2;i<=n;i++)
		{
			if(mintemp>window[i].poptime)
			{
				mintemp=window[i].poptime;
				minwindow=i;
			}
		}
       //将index这个人排到最先出来的窗口
		window[minwindow].q.pop();
		window[minwindow].q.push(usetime[index]);
		window[minwindow].poptime+=window[minwindow].q.front();
        if(window[minwindow].endtime>=540) sorry[index]=true;
		window[minwindow].endtime+=usetime[index];
	    result[index]=window[minwindow].endtime;
		index++;
	}

	for(int i=1;i<=q;i++)
	{
		int query;
		scanf("%d",&query);
		if(sorry[query]==true) printf("Sorry\n");
		else printf("%02d:%02d\n",(result[query]+480)/60,(result[query]+480)%60);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值