hdoj 1509 Windows Message Queue 优先队列

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4049    Accepted Submission(s): 1591


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
  
  
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 


题目大意是windows的信息队列是按照优先级执行的,输入PUT时输入一行信息,包括一个字符串和两个整数,第一个整数是元素,第二个是优先级,输入GET指令时按照优先级的从低到高输出信息, 当两个优先级相同时按照输入的顺序输出 。练习使用优先队列。

注意: 当两个优先级相同时按照输入的顺序输出。在程序中记录输入次序,在重载运算符的时候注意比较俩的次序,我在这里贡献了多次WA。

代码:

<span style="color:#1a5cc8;">#include<stdio.h>
#include<queue>
#include<string.h>
#include<string>
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstdlib>
#include <cstring>
using namespace std;

struct node//自定义优先队列的优先级
{
    char name[200];
    int priority,val,i;

    bool operator < (const node a) const
    {
        if(priority!=a.priority)//先按照优先级比较
        return a.priority < priority;
        </span><span style="color:#ff0000;">else//比较输入顺序
        {
            return i>a.i;
        }</span><span style="color:#1a5cc8;">
    }
};

int main()
{
    priority_queue<node>q;//开一个node型的优先队列
    char com[200];
    int k=0;
    while(~scanf("%s",com))
    {
        node mes;
        if(strcmp(com,"GET")==0)
        {
            if(!q.empty())
            {
                node t=q.top();
                printf("%s %d\n",t.name,t.val);
                q.pop();
            }
            else
            {
                printf("EMPTY QUEUE!\n");
            }
        }
        else if(strcmp(com,"PUT")==0)
        {
            scanf("%s%d%d",mes.name,&mes.val,&mes.priority);
            mes.i=++k;
            q.push(mes);
        }
    }
    return 0;
}
</span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值