hdoj 1509 Windows Message Queue(优先队列)

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4309 Accepted Submission(s): 1701


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input
  
  
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET

Sample Output
  
  
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!

Author
ZHOU, Ran

Source

题目大意:

是当输入PUT时,接收一个msg的名称,参数和优先级,将它放在队列尾,当输入GET时,如果队列是空的,输出EMPTY QUEUE!,如果非空,输出优先级最高的那条msg的名称和参数(也就是数值最小的),并把它从队列里删除。


解题思路:

1)这道题根据输出中包含“queue”,那么我们可以考虑一下使用queue(队列)来解决这个问题。然而在队列中,要出现后进先出的情况,这时我们便可以考虑使用优先队列来解决这个问题。。。。

2)。在这里,我对这个比较函数有一些自己的看法(可能不正确).其实,return
a<b

,这个意思应该是“维持默认的排序方式”,而在一般情况下,默认的排序方式即为升序。而return a  > b则表示采用相反于默认排序的方式进行排序。

在优先队列中,默认的排序方式是降序排序。

#include<cstdio>
#include<cstring>
#include<queue>
#include<cstdlib>
#include<algorithm>
using namespace std;
struct node
{
 char name[20];
 int level;//优先权 
 int id;//进队顺序 
 int par;//作业的参数 
 friend  bool operator<(node a,node b)
 {
   if(a.level!=b.level)//先输出优先级高的(即level小的) 
     return b.level<a.level;
   else                //优先级相同时,根据进队顺序输出 
      return b.id<a.id;
 }
};
int main()
{
   char opr[10];
   int count=0;	
   node mesg;
   priority_queue<node>q;
   while(~scanf("%s",opr))
   {
   
	if(strcmp(opr,"PUT")==0)
   	 {
   	 	scanf("%s%d%d",mesg.name,&mesg.par,&mesg.level);
   	 	mesg.id=count++;//先进来的顺序小 
   	 	q.push(mesg);
	 }
	 else if(strcmp(opr,"GET")==0)
	 {
	 	if(!q.empty())
	 	{
	 	   node msg=q.top();
	 	   q.pop();
		   printf("%s %d\n",msg.name,msg.par);
		} 
	 	else
	 	 printf("EMPTY QUEUE!\n");
	 }
   }
   return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值