hdu6038

Function

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1393    Accepted Submission(s): 647


Problem Description
You are given a permutation  a  from  0  to  n1  and a permutation  b  from  0  to  m1 .

Define that the domain of function  f  is the set of integers from  0  to  n1 , and the range of it is the set of integers from  0  to  m1 .

Please calculate the quantity of different functions  f  satisfying that  f(i)=bf(ai)  for each  i  from  0  to  n1 .

Two functions are different if and only if there exists at least one integer from  0  to  n1  mapped into different integers in these two functions.

The answer may be too large, so please output it in modulo  109+7 .
 

Input
The input contains multiple test cases.

For each case:

The first line contains two numbers  n,   m (1n100000,1m100000)

The second line contains  n  numbers, ranged from  0  to  n1 , the  i -th number of which represents  ai1 .

The third line contains  m  numbers, ranged from  0  to  m1 , the  i -th number of which represents  bi1 .

It is guaranteed that  n106,   m106 .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
  
  
3 2 1 0 2 0 1 3 4 2 0 1 0 2 3 1
 

Sample Output
  
  
Case #1: 4 Case #2: 4
思路:这其实一道关于数学映射的题目,只要找到a[i]与i之间形成的环和b[i]与i之间的环,并把他们所形成的环的大小记录下来。
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
const int MOD=1e9+7;
vector<int>a1;
vector<int>a2;
int v[100005];
int main()
{
    int m,n;
    int b[100005],c[100005];
    int k=1;
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        int i,j;
        a1.clear();
        a2.clear();
        for(i=0;i<m;i++)
        {
            scanf("%d",&b[i]);
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&c[i]);
        }
        memset(v,0,sizeof(v));
        int x,len;
        for(i=0;i<m;i++)
        {
            x=i,len=1;
            if(!v[i])
            {
                v[i]=1;
                while(b[x]!=i)
                {
                    x=b[x];
                    v[x]=1;
                    len++;
                }
                a1.push_back(len);
            }
        }
        memset(v,0,sizeof(v));
        for(i=0;i<n;i++)
        {
            x=i,len=1;
            if(!v[i])
            {
                v[i]=1;
                while(c[x]!=i)
                {
                    x=c[x];
                    v[x]=1;
                    len++;
                }
                a2.push_back(len);
            }
        }
        int ans=1;
        for(i=0;i<a1.size();i++)
        {
            int ans1=0;
            for(j=0;j<a2.size();j++)
            {
                if(a1[i]%a2[j]==0)
                {
                    ans1=(ans1+a2[j])%MOD;
                }
            }
            ans=(ans*ans1)%MOD;
        }
        printf("Case #%d: %d\n",k++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值