poj1034The dog task

The dog task
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3182 Accepted: 1283 Special Judge

Description

Hunter Bob often walks with his dog Ralph. Bob walks with a constant speed and his route is a polygonal line (possibly self-intersecting) whose vertices are specified by N pairs of integers (Xi, Yi) ? their Cartesian coordinates. 
Ralph walks on his own way but always meets his master at the specified N points. The dog starts his journey simultaneously with Bob at the point (X1, Y1) and finishes it also simultaneously with Bob at the point (XN, YN). 
Ralph can travel at a speed that is up to two times greater than his master's speed. While Bob travels in a straight line from one point to another the cheerful dog seeks trees, bushes, hummocks and all other kinds of interesting places of the local landscape which are specified by M pairs of integers (Xj',Yj'). However, after leaving his master at the point (Xi, Yi) (where 1 <= i < N) the dog visits at most one interesting place before meeting his master again at the point (Xi+1, Yi+1). 
Your task is to find the dog's route, which meets the above requirements and allows him to visit the maximal possible number of interesting places. The answer should be presented as a polygonal line that represents Ralph's route. The vertices of this route should be all points (Xi, Yi) and the maximal 
aces (Xj',Yj'). The latter should be visited (i.e. listed in the route description) at most once. 
An example of Bob's route (solid line), a set of interesting places (dots) and one of the best Ralph's routes (dotted line) are presented in the following picture: 

Input

The first line of the input contains two integers N and M, separated by a space ( 2 <= N <= 100 ,0 <= M <=100 ). The second line contains N pairs of integers X1, Y1, ..., XN, YN, separated by spaces, that represent Bob's route. The third line contains M pairs of integers X1',Y1',...,XM',YM', separated by spaces, that represent interesting places. 
All points in the input file are different and their coordinates are integers not greater than 1000 by the absolute value. 

Output

The first line of the output should contain the single integer K ? the number of vertices of the best dog's route. The second line should contain K pairs of coordinates X1'',Y1'' , ...,Xk'',Yk'', separated by spaces, that represent this route. If there are several such routes, then you may write any of them.

Sample Input

4 5
1 4 5 7 5 2 -2 4
-4 -2 3 9 1 2 -1 3 8 -3

Sample Output

6
1 4 3 9 5 7 5 2 1 2 -2 4
题意:Bob和他的狗一起溜达,狗移动的速度是Bob的2倍。先给出Bob行走路线上的一些点,然后给出小狗能够玩的点,在Bob去下一个点的时候狗可以去其他地方玩。

思路:这题就是二分最大匹配的题目,注意建图就可以了。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <cmath>
using namespace std;
int g[105][105];
struct node
{
    int x,y;
}a[105],b[105];
int m,n;
double getdis(node a,node b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int link[105];
bool used[105];
int ss[105];
bool dfs(int u)
{
    int i;
    for(i=0;i<n;i++)
    {
        if(g[u][i]&&!used[i])
        {
            used[i]=true;
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int i,j;
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
        }
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&b[i].x,&b[i].y);
        }
        memset(g,0,sizeof(g));
        for(i=0;i<m-1;i++)
        {
            for(j=0;j<n;j++)
            {
                double c=getdis(a[i],a[i+1]);
                double d=getdis(a[i],b[j]);
                double e=getdis(a[i+1],b[j]);
                if(d+e-c-c<10e-8)
                    g[i][j]=1;
            }
        }
        int res=0;
        memset(link,-1,sizeof(link));
        for(i=0;i<m-1;i++)
        {
              memset(used,false,sizeof(used));
              if(dfs(i))res++;
        }
        cout<<res+m<<endl;
        memset(ss,-1,sizeof(ss));
        for(i=0;i<n;i++)
        {
            if(link[i]!=-1)
                ss[link[i]]=i;
        }
        for(i=0;i<m-1;i++)
        {
            printf("%d %d ",a[i].x,a[i].y);
            if(ss[i]!=-1)
            {
                printf("%d %d ",b[ss[i]].x,b[ss[i]].y);
            }
        }
        printf("%d %d\n",a[m-1].x,a[m-1].y);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值