poj1236Network of Schools

Network of Schools
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20438 Accepted: 8065

Description

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B 
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school. 

Input

The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

Output

Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0

Sample Output

1
2
题意:给定一个有向图,求: 至少要选几个顶点,才能做到从这些顶点出发,可以到达全部顶点;至少要加多少条边,才能
使得从任何一个顶点出发,都能到达全部顶点
思路:第一个问直接求入度为0的个数即可,第二个问求入度和出度为0的个数中大的那个。
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
using namespace std;
const int N=55555;
int dfn[N],low[N],belong[N];
bool instack[N];
int flag[N];
int used[N];
int in[N],out[N];
int cnt,index;
int m,n;
vector<int>g[N];
stack<int>s;
void init()
{
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(instack,false,sizeof(instack));
    memset(in,0,sizeof(in));
    memset(out,0,sizeof(out));
    index=cnt=0;
    for(int i=0;i<=n;i++)
    {
        g[i].clear();
    }
    while(!s.empty())
    {
        s.pop();
    }
}
void tarjan(int u)
{
    dfn[u]=low[u]=++index;
    s.push(u);
    instack[u]=true;
    int v;
    for(int i=0;i<g[u].size();i++)
    {
        v=g[u][i];
        if(!dfn[v])
        {
            tarjan(v);
            low[u]=min(low[v],low[u]);
        }
        else if(instack[v])
        {
            low[u]=min(low[u],dfn[v]);
        }
    }
    if(dfn[u]==low[u])
    {
        cnt++;
        do{
            v=s.top();
            s.pop();
            instack[v]=false;
            belong[v]=cnt;
        }while(u!=v);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        int i;
        int a;
        int j;
        init();
        for(i=1;i<=n;i++)
        {
            while(scanf("%d",&a)&&a)
            {
                g[i].push_back(a);
            }
        }
        for(i=1;i<=n;i++)
        {
            if(!dfn[i])
                tarjan(i);
        }
        for(i=1;i<=n;i++)
        {
            for(j=0;j<g[i].size();j++)
            {
                int v=g[i][j];
                if(belong[i]!=belong[v])
                {
                    out[belong[i]]++;
                    in[belong[v]]++;
                }
            }
        }
        int ans=0,ans1=0;
        for(i=1;i<=cnt;i++)
        {
            if(out[i]==0)
            {
                ans++;
            }
            if(in[i]==0)
            {
                ans1++;
            }
        }
        if(cnt==1)
        {
            printf("1\n0\n");
        }
        else printf("%d\n%d\n",ans1,max(ans,ans1));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值