PAT (Advanced Level) Practise —— 1015. Reversible Primes (20)

http://pat.zju.edu.cn/contests/pat-a-practise/1015

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No


#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>

using namespace std;

char str[100000];

// 判断素数:看2到sqrt(n)中是否有数能整除n
bool isPrime(int n)
{
	if (n <= 1) 
		return false;
	for (int i = 2; i * i <= n; ++i)	// 避免使用sqrt函数
		if (n % i == 0)
			return false;
	return true;
}

// 将十进制数n转换为d(<10)进制数后的逆序结果保存在字符串str中 
void convert1(int n, int d, char *str)
{
    int len = 0; // 字符串长度
    while (n)
    {
        str[len++] = (char)((n % d) + '0');
        n = n / d;
    }
    str[len] = '\0'; // don't forget!
}

// 将保存在str中的d(<10)进制数转换为十进制数返回 
int convert2(char *str, int d)
{
    int len = strlen(str), w = 1, sum = 0;
	for (int i = len - 1; i >= 0; --i)
	{
	    sum += w * (int)(str[i] - '0');
		w *= d;
	}
	
	return sum;
}

// 对每个case进行判断
int judge(int n, int d)
{
	if (!isPrime(n) )           // 10进制数n是否是素数 
	    return 0;
	convert1(n, d, str);        // n转换为d进制 
	// 10进制数n在d进制下的逆序是否为素数 
	if (!isPrime(convert2(str, d) ) )          
	    return 0;
	return 1;
}

int main()
{
    int n, d;
	char *out[2] = {"No", "Yes"};
	while (scanf("%d", &n) != EOF && n >= 0)
	{
		scanf("%d", &d);
		printf("%s\n", out[judge(n, d)]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值