PAT (Advanced Level) Practise —— 1001. A+B Format (20)

http://pat.zju.edu.cn/contests/pat-a-practise/1001


Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

不想写判断语句,用sprintf函数和两个字符串完成:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>

char outStr1[10];
char outStr2[10];

int main()
{
	int a, b, sum;
	scanf("%d%d", &a, &b);
	sum = a + b;
	if (sum < 0) printf("-");
	sprintf(outStr1, "%d", abs(sum));
	int len = strlen(outStr1);
	int i, j, k;
	for (i = len-1, j = 0, k = 1; i >= 0; i--, k++)
	{
		outStr2[j++] = outStr1[i];
		if (k%3 == 0 && i != 0)
		{
			outStr2[j++] = ',';
		}
	}
	int len2 = strlen(outStr2);
	for (i = len2-1; i >= 0; i--)
	{
		printf("%c", outStr2[i]);
	}
	printf("\n");

	return 0;
}

不用字符串,利用 printf函数控制输出格式:( http://alvenxuan.iteye.com/blog/1450533)

#include <stdio.h>

int main()
{
	int a, b, sum;
	while (scanf("%d%d", &a, &b) != EOF)
	{
		sum = a + b;
		if (sum < 0)
		{
			sum = -sum;
			printf("-");
		}
		if (sum >= 1000000)
		{
			printf("%d,%03d,%03d\n", sum/1000000, (sum/1000)%1000, sum%1000);
		}
		else if (sum >= 1000)
		{
			printf("%d,%03d\n", sum/1000, sum%1000);
		}
		else
		{
			printf("%d\n", sum);
		}
	}
	return 0;
}

使用Python:( http://www.cnblogs.com/szhang/archive/2013/01/16/2863511.html)

a,b = raw_input().split()
print format(int(a)+int(b),",")

Python在字符处理上真的很强大!(字符串的split函数默认以空格' '作为分割,format函数的第二个参数为","时自动将输出数字以","分割)





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值