[kuangbin]专题四 最短路练习 Heavy Transportation POJ - 1797【dijkstra】

【题目描述】
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
背景
Hugo heavy很高兴,在Cargolifter项目崩溃后他现在能扩大生意。但他需要一个聪明的人,他告诉他是否真的有办法从他的客户建造他的巨型钢吊车的地方到需要它的地方,在那里所有的街道都可以承载重量。
幸运的是,他已经有了城市的规划,所有的街道和桥梁,以及所有允许的重量。不幸的是,他不知道如何找到最大重量的能力,以告诉他的客户,起重机可能变得多重。但你肯定知道。
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
问题
给出了城市的规划,由交叉路口之间的街道(有重量限制)描述,从1到n。你的任务是找到最大重量,可以从交叉1(Hugo的地方)到交叉n(客户的地方)。您可以假设至少有一条路径。所有的街道都可以双向行驶。

【输入】
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
第一行包含一个数表示场景(城市计划)的数目
每组测试样例的第一行给出每个城市的路口数n(1<=n<=1000)和街道数m。
后面m行包含3个整数指定街道起点和终点交叉口以及允许的最大重量,且不大于1000000.
每对过道之间最多有一条街。

【输出】
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
每个场景的输出,以"Scenario #i:"开始,i表示从1开始的场景的数字,然后打印一行包含雨果运输给顾客的最大允许重量。用空行终止方案的输出。

【样例输入】
1
3 3
1 2 3
1 3 4
2 3 5

【样例输出】
Scenario #1:
4

题目链接:https://cn.vjudge.net/problem/POJ-1797

dijkstra模板变形

代码如下:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
static const int MAXN=1000;
int E[MAXN+10][MAXN+10],d[MAXN+10],n;
bool vis[MAXN+10];
void dijkstra()
{
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++)
        d[i]=E[1][i];
    for(int i=1;i<n;i++)
    {
        int x=0;
        for(int j=1;j<=n;j++)
            if(!vis[j] && (x==0 || d[j]>d[x]))
                x=j;
        vis[x]=true;
        for(int y=1;y<=n;y++)
            d[y]=max(d[y],min(d[x],E[x][y]));
    }
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0),cout.tie(0);
    int T;
    cin>>T;
    for(int kase=1;kase<=T;kase++)
    {
        int m;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                E[i][j]=0;
        for(int i=1;i<=m;i++)
        {
            int x,y,z;
            cin>>x>>y>>z;
            E[x][y]=max(E[x][y],z);
            E[y][x]=E[x][y];
        }
        dijkstra();
        cout<<"Scenario #"<<kase<<":"<<endl;
        cout<<d[n]<<endl;
        cout<<endl;
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值