POJ 1797 Heavy Transportation 【最短路思维+最大承载】

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4


题目大意:给你n和m , 要你求从1到达n的最大承载量 , 且有m跳路 。 对图进行操作稍微修改                   一下最短路就好, 对于样例1,要到达3点, 要么是1->2->3 要么是 1->3 ; 对于前  者,由于它给出的权值是承载量;所以第一个图的承载量定然得按最小值计算是3,所 以后者直接就是4 ; 既得答案; 这里进行的不是加边操作, 而是比较操作 ;改一下就                  行

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define inf 0Xfffffff
using namespace std ;
int dp[5000][5000] , vis[5000] , dis[5000] , t , n , m ; 
void dijk()
{
	for(int i = 1 ; i<=n;i++) dis[i] = dp[1][i];
	int k , mini ;
	for(int i = 1 ; i<=n;i++)
	{
		mini = -1 ;
		for(int j = 1 ; j<=n ;j++)	if(!vis[j]&&dis[j]>mini) mini = dis[k=j];
		vis[k] =1 ; 
		for(int j = 1 ; j<=n ;j++)  if(!vis[j]&&dis[j] < min(dp[k][j] ,dis[k] )) dis[j] = min(dis[k] , dp[k][j]);
	}
}
int main()
{
	cin>>t;
	for(int cas = 1 ; cas <=t ; cas++)
	{
		scanf("%d%d",&n,&m);
		for(int i = 0 ; i<=n;i++)
		{
			for(int j = 0 ; j <=n; j++)
			{
				dp[i][j] = -inf ;
			}
			dis[i] = inf ;
			vis[i] = 0;
			dp[i][i] = 0 ;
		}
		for(int i = 0 ; i < m; i++)
		{
			int a , b , len ;
			scanf("%d%d%d",&a,&b,&len);
			if(dp[a][b] < len) dp[a][b] = dp[b][a] = len;
		}
		dijk();
		printf("Scenario #%d:\n",cas);
		cout<<dis[n]<<endl<<endl;
	}
	return 0 ; 
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值