历届试题 打印十字图

问题描述

小明为某机构设计了一个十字型的徽标(并非红十字会啊),如下所示:

..$$$$$$$$$$$$$..
..$...........$..
$$$.$$$$$$$$$.$$$
$...$.......$...$
$.$$$.$$$$$.$$$.$
$.$...$...$...$.$
$.$.$$$.$.$$$.$.$
$.$.$...$...$.$.$
$.$.$.$$$$$.$.$.$
$.$.$...$...$.$.$
$.$.$$$.$.$$$.$.$
$.$...$...$...$.$
$.$$$.$$$$$.$$$.$
$...$.......$...$
$$$.$$$$$$$$$.$$$
..$...........$..
..$$$$$$$$$$$$$..

对方同时也需要在电脑dos窗口中以字符的形式输出该标志,并能任意控制层数。

输入格式
一个正整数 n (n<30) 表示要求打印图形的层数。
输出格式
对应包围层数的该标志。
样例输入1
1
样例输出1
..$$$$$..
..$...$..
$$$.$.$$$
$...$...$
$.$$$$$.$
$...$...$
$$$.$.$$$
..$...$..
..$$$$$..
样例输入2
3
样例输出2
..$$$$$$$$$$$$$..
..$...........$..
$$$.$$$$$$$$$.$$$
$...$.......$...$
$.$$$.$$$$$.$$$.$
$.$...$...$...$.$
$.$.$$$.$.$$$.$.$
$.$.$...$...$.$.$
$.$.$.$$$$$.$.$.$
$.$.$...$...$.$.$
$.$.$$$.$.$$$.$.$
$.$...$...$...$.$
$.$$$.$$$$$.$$$.$
$...$.......$...$
$$$.$$$$$$$$$.$$$
..$...........$..
..$$$$$$$$$$$$$..
提示

请仔细观察样例,尤其要注意句点的数量和输出位置。


#include<iostream>

using namespace std;
int temp;
void prin()
{
    char table[temp][temp];
    for(int i=0;i<temp;i++)
        for(int j=0;j<temp;j++)
            table[i][j]='.';
    for(int i=temp-1;i>temp-4;i--)
        {
        table[temp-1][i]='$';
        table[i][temp-1]='$';
        }
    int space=2;
    for(int i=0;i<temp;i=i+2)
    {
        for(int j=space;j<temp;j++)
        {
            table[i][j]='$';
            table[j][i]='$';
        }
        space=space+2;
    }
    for(int i=2,j=2;i<temp&&j<temp;)
    {   table[i][j]='$';
        table[i-1][j]='$';
        table[i][j-1]='$';
        i=i+2;
        j=j+2;
    }
for(int i=0;i<temp;i++)
  {
      for(int j=0;j<temp;j++)
            cout<<table[i][j];
      for(int j=temp-2;j>=0;j--)
            cout<<table[i][j];
        cout<<endl;
  }
  for(int i=temp-2;i>=0;i--)
  {
      for(int j=0;j<temp;j++)
            cout<<table[i][j];
      for(int j=temp-2;j>=0;j--)
            cout<<table[i][j];
        cout<<endl;
  }
}
int main()
{
    int n;
    cin>>n;
    temp=2*n+3;
    prin();
    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值