Protecting the Flowers (贪心)

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroysDi (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cowi to its barn requires 2 × Ti minutes (Ti to get there andTi to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input
Line 1: A single integer N
Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics
Output
Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input
6
3 1
2 5
2 3
3 2
4 1
1 6
Sample Output
86
Hint
FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.、

题意:

有N头牛在花园里破坏花,因此老汉要把牛全部运会圈里,运回每头牛的所花时间不同,分别为Ti,每头牛每分钟破坏花的数量为Di,求把所有牛运回,使花破坏最少的数量

思路:

假设有两头牛 A1,A2,运回A1 花时间 T1,每分钟破坏花的数量为D1;运回A2 花时间 T2,每分钟破坏花的数量为D2

如果先运回A1  破坏花的数量为  2*T1*D2

如果先运回A2  破坏花的数量为  2*T2*D1

两式同时除以2* D1*D2  则 为T1/D1  T2/D2

所以 对于每头牛 T/D 越小 越先运回

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
    int d;
    int t;
    double num;
}cow[100050];
int cmp(node a,node b){
    return a.num<b.num;
}
int main(){
    int n;
    scanf("%d",&n);
    int i;
    int D=0;
    for(i=0;i<n;i++){
        scanf("%d%d",&cow[i].t,&cow[i].d);
        cow[i].num=cow[i].t/(cow[i].d*1.0);
       // printf("%.3f\n",cow[i].num);
        D+=cow[i].d;
    }
   // printf("D %d\n",D);
    sort(cow,cow+n,cmp);
   // D-=cow[n-1].d;
    long long  sum=0;
    for(i=0;i<n;i++){

        D-=cow[i].d;  //牛被运走 对花无破坏
        sum+=cow[i].t*2*D; //剩下所有牛每分钟破坏花的数量  乘以 运牛来回所花的时间
    }
    printf("%I64d\n",sum);
return 0;
}




  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
阅读下面材料,在空格处填入适当的内容(1个单词)或使用括号中单词的正确形式。 If including inter-state sections, those not protecting the northern border of China, the oldest _____56____(exist) section of the Great Wall of China was the Qi State "Great Wall". It stretches for over 500 kilometers (300 miles) from the Yellow River at Jinan eastwards to the East China Sea, almost ___57____(divide) Shandong Province in half. The "Great Wall" of the Qi State was ___58____(initial) built around 650 BC, and expended during the Warring States Period (475–221 BC). Before the Qi State Wall was built, natural barriers, i.e. rivers and mountain ranges, formed ____59_____ only defensible boundaries between territories as barriers ___60____ enemies. The State of Qi built its Great-Wall-esque military barrier along its southern border to prevent attacks from the State of Lu and the State of Chu. However, rapid development and ____61____(construct) have brought many new problems and challenges in protecting the wall. ____62____ is necessary to provide a solid legal guarantee for its conservation. To tackle the challenges, Shandong Province has passed a regulation protecting the structure____63____will take effect on Jan. 1. This year, Shandong has added 860 patrol posts in seven cities along the Qi wall, mainly recruiting farmers living nearby. Guo Jialian has been patrolling the section of the wall in Guangli village for three months. "I need to check ____64______ there is any damage to the wall that is caused by people digging earth from it. Awareness of protecting the Qi wall _____65_____ (enhance) in recent years. We all know the wall is a cultural relic," says Guo, adding that he frequently sees tourists coming to visit the ancient structure.
最新发布
02-06

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值