Common Subsequence (LCS)

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output
4
2
0
题意:求最长公共子序列(LCS)的长度

思路:

引进一个二维数组dp[][],用dp[i][j]记录s1[i]与s2[j](从1开始放) 的LCS 的长度.

dp【i】【j】=   0         if(i==0||j==0)

                      =maxx( dp[i-1][j-1 ]+ same(i,j) , dp[i-1][j] , dp[i][j-1 ]  );

代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define MAX 1005
using namespace std;
int dp[MAX][MAX];
char s1[MAX],s2[MAX];
int same(int a,int b){//判断s1[a],s2[b]是否相等
    if(s1[a]==s2[b]) return 1;
    return 0;
}
int maxx(int a,int b,int c){ //求a,b,c三者的最大值
    int m=-1;
    m=max(a,b);
    m=max(m,c);
    return m;
}
int main(){
    while(scanf("%s%s",s1+1,s2+1)!=EOF){//字符串从1开始
        memset(dp,0,sizeof(dp));
        int len1=strlen(s1+1),len2=strlen(s2+1);
        int i,j;
        for(i=1;i<=len1;i++){
            for(j=1;j<=len2;j++)
                dp[i][j]=maxx(dp[i-1][j-1]+same(i,j),dp[i-1][j],dp[i][j-1]);
        }
        printf("%d\n",dp[len1][len2]);
    }
return 0;
}

附带打印路径模板

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N = 1005;
char a[N],b[N];
int dp[N][N],p[N][N];
void Print(int i,int j){  //打印最长公共子序列 
	if(i<0||j<0) return;
	if(p[i][j]==1){
		Print(i-1,j-1);
		printf("%c",a[i-1]);
	}
	else if(p[i][j]==2) Print(i-1,j);
	else Print(i,j-1);
}
void LCS(){//求最长公共子序列 
	int n=strlen(a),m=strlen(b);
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			if(a[i-1]==b[j-1]){
				dp[i][j]=dp[i-1][j-1]+1;
				p[i][j]=1;
			}
			else if(dp[i-1][j]>=dp[i][j-1]){
				dp[i][j]=dp[i-1][j-1];
				p[i][j]=2;
			}
			else{
				dp[i][j]=dp[i][j-1];
				p[i][j]=3;
			}
		}
	}
	printf("%d\n",dp[n][m]);
	Print(n,m);
}
int main(){
	scanf("%s%s",a,b);
	LCS();
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值