Bomb(数位dp入门题)

HDU 3555-----Bomb
Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15
Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

这道题的大致意思就是,给你一个数r,让你去求解[1,r]之间数位上含’49’数的个数

这道题是1道简单的数位dp。跟不要62差不多,这里也不多讲了,希望能够看一下不要62。链接不要62(主要看代码)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long LL;
int a[100];
LL dp[100][3];
//f[pos][sta]
//sta==0时 最后一位不是4且不含49;
//1最后一位是4
//2 含49
LL dfs(int pos,int sta,bool lim)
{
    if(pos<=0)
        return sta==2;
    if(!lim&&dp[pos][sta]!=-1)
        return dp[pos][sta];
    int up = lim ? a[pos] : 9;
    LL ans = 0;
    for (int i = 0; i <= up;i++)
    {
        int sta1 = sta;
        if(sta==1&&i==9)
            sta1 = 2;
        else if(sta==0&&i==4)
            sta1 = 1;
        else if(sta==1&&i!=4)
            sta1=0;
        ans+=dfs(pos - 1, sta1, lim && i ==up);
    }
    if(!lim)
        dp[pos][sta] = ans;
    return ans;
}
LL solve(LL x)
{
    int pos = 0;
    while(x)
    {
        a[++pos] = x % 10;
        x /= 10;
    }
    return dfs(pos, 0, 1);
}
int main(){
    LL r;
    int t;
    scanf("%d", &t);
    while(t--){
        memset(dp, -1, sizeof dp);
        scanf("%lld", &r);
        printf("%lld\n", solve(r));
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值