Cube

Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
Output
For each test case, you should output the number of pairs that was described above in one line.
Sample Input
1
2
3
Sample Output
0
16
297


        
  
The results will not exceed int type.
Hint
Hint
        
 
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int dp[35];
int F(int n){
	int sum=1;
    sum*=n*(n-1);
    sum/=2;
	return sum;
}
void init(){
	dp[1]=0;
	for(int i=2;i<=30;i++){
		int n=(int)pow(i,3);
		dp[i]=F(n)-(int)pow(i,2)*3*(i-1);
	}
}
int main(){
	int m;
	init();
	while(scanf("%d",&m)!=EOF){
		printf("%d\n",dp[m]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值