Treasure Exploration (最少路径覆盖+传递闭包)

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?
Input
The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
Output
For each test of the input, print a line containing the least robots needed.
Sample Input
1 0
2 1
1 2
2 0
0 0
Sample Output
1
1
2
 

题意:给一个有向无环图,有n个点,m条有向边。一个机器人可以从任意点开始沿着边的方向走下去。对于每一个机器人:走过的点不能再走过。对于每个点可被多个机器人走。问你最少用几个机器人可以走完所有的n个点,不同的机器人可以走相同的点(two different robots may contain some same point)。

分析:路径可以相互交叉,所以就是最小路径覆盖+Warshell传递闭包。

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
const int N = 510;
int match[N],vis[N];
int n,m;
int e[N][N];
void init(){
	memset(e,0,sizeof(e));
}
void Warshell(){//传递闭包 
	for(int i=1;i<=n;i++)
	for(int j=1;j<=n;j++)
	if(!e[i][j])
	for(int k=1;k<=n;k++)
	if(e[i][k]&&e[k][j]){
		e[i][j]=1;
		break;
	}
}
int Find(int u){
	for(int i=1;i<=n;i++){
		if(e[u][i]&&!vis[i]){
			vis[i]=1;
			if(match[i]==-1||Find(match[i])){
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int MaxMatch(){ 
	memset(match,-1,sizeof(match));
	int ans=0;
	for(int i=1;i<=n;i++){
		memset(vis,0,sizeof(vis));
		ans+=Find(i);
	}
	return ans;
}
int main(){
	while(scanf("%d%d",&n,&m)!=EOF){
		if(n==0&&m==0) break;
		init();
		for(int i=0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			e[a][b]=1;
		}
		Warshell();
		printf("%d\n",n-MaxMatch());
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值