HDU-1350 Taxi Cab Scheme(最小路径覆盖)

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible, there is also a need to schedule all the taxi rides which have been booked in advance. Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides.

For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest, at least one minute before the new ride’s scheduled departure. Note that some rides may end after midnight.

Input
On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.
Output
For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.
Sample Input
2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11
Sample Output
1
2

题意:n个出租车订单,每个订单有一个出发时间、出发地点、目的地点(计算过程的花费时间),当完成一个订单时,若能从当前订单的目的地点赶到另一个订单的出发地点(到达另一出发地点时至少距该订单开始还有1分钟),则可以进行下一单。问最少需要派多少辆出租车才能完成所有的订单。

思路:乍一看时跟一个贪心的题很像,但是这题加了地点距离的限制,所以其实是一个经典的DAG最小路径覆盖问题。对当前订单完成之后和能够赶到的下一订单之间建立有向边,从而建立出一个DAG,而对于本题就是求一个最小路径覆盖。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
using namespace std;
const int N = 510;
int val[N],keep[N];
int a[N],b[N],c[N],d[N];
int match[N],vis[N];
vector<int>G[N];
int n;
void init(){
	for(int i=0;i<=n;i++)
	   G[i].clear();
}
int Find(int u){
	for(int i=0;i<G[u].size();i++){
		int v=G[u][i];
		if(!vis[v]){
			vis[v]=1;
			if(match[v]==-1||Find(match[v])){
				match[v]=u;
				return 1;
			}
		}
	}
	return 0;
}
int MaxMatch(){
	memset(match,-1,sizeof(match));
	int ans=0;
	for(int i=1;i<=n;i++){
		memset(vis,0,sizeof(vis));
		ans+=Find(i);
	}
	return ans;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		init();
		for(int i=1;i<=n;i++){
			int hh,mm;
			scanf("%d:%d%d%d%d%d",&hh,&mm,&a[i],&b[i],&c[i],&d[i]);
			val[i]=hh*60+mm;
			keep[i]=abs(a[i]-c[i])+abs(b[i]-d[i]);
			for(int j=1;j<i;j++){
				if(val[i]+keep[i]+abs(a[j]-c[i])+abs(b[j]-d[i])<val[j])
				   G[i].push_back(j);
				if(val[j]+keep[j]+abs(a[i]-c[j])+abs(b[i]-d[j])<val[i])
				   G[j].push_back(i);
			}
		}
		int ans=MaxMatch();
		printf("%d\n",n-ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值