Hotaru's problem (马拉车算法)

Hotaru Ichijou recently is addicated to math problems. Now she is playing with N-sequence.
Let's define N-sequence, which is composed with three parts and satisfied with the following condition:
1. the first part is the same as the thrid part,
2. the first part and the second part are symmetrical.
for example, the sequence 2,3,4,4,3,2,2,3,4 is a N-sequence, which the first part 2,3,4 is the same as the thrid part 2,3,4, the first part 2,3,4 and the second part 4,3,2 are symmetrical.

Give you n positive intergers, your task is to find the largest continuous sub-sequence, which is N-sequence.

Input
There are multiple test cases. The first line of input contains an integer T(T<=20), indicating the number of test cases.

For each test case:

the first line of input contains a positive integer N(1<=N<=100000), the length of a given sequence

the second line includes N non-negative integers ,each interger is no larger than 109
, descripting a sequence.
Output
Each case contains only one line. Each line should start with “Case #i: ”,with i implying the case number, followed by a integer, the largest length of N-sequence.

We guarantee that the sum of all answers is less than 800000.
Sample Input
1
10
2 3 4 4 3 2 2 3 4 4
Sample Output
Case #1: 9
#include<iostream>
#include<stdio.h>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 100005;
int a[N];
int p[N*2],arr[N*2];
void Manacher(int a[],int n){
	arr[0]=Inf;
	for(int i=1;i<=n;i++){
		arr[i*2-1]=a[i];
		arr[i*2]=Inf;
	}
	arr[n*2+1]=Inf;
	int mx=0,id=0;
	for(int i=0;i<2*n+1;i++){
		p[i]=mx>i?min(p[2*id-i],mx-i):1;
		while(arr[i+p[i]]==arr[i-p[i]]) ++p[i];
		if(mx<i+p[i]){
			mx=i+p[i];
			id=i;
		}
	}
}
int main(){
	int T;
	scanf("%d",&T);
	int cas=0;
	while(T--){
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		   scanf("%d",&a[i]);
		Manacher(a,n);
		int ans=0;
		for(int i=1;i<=2*n+1;i++){
			for(int j=p[i]+i-1;j-i>ans;j-=2){//j为以i为中心的回文字符串最后一个字符的位置 
				if(j-i<=p[j]){//j-i==p[i]-1  即以i为中心的原字符串的长度
					ans=max(ans,j-i);
					break;
				}
			}
		}
		printf("Case #%d: %d\n",++cas,ans/2*3);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值