transaction transaction transaction HDU - 6201 (无向图最长路SPFA)

Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in it city. Kelukin will take taxi, whose price is 1yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n

cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.

Input

The first line contains an integer T

(1≤T≤10) , the number of test cases.
For each test case:
first line contains an integer n (2≤n≤100000) means the number of cities;
second line contains n numbers, the ith number means the prices in ith city; (1≤Price≤10000)
then follows n−1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is zkm (1≤z≤1000)

.

Output

For each test case, output a single number in a line: the maximum money he can get.

Sample Input

1  
4  
10 40 15 30  
1 2 30
1 3 2
3 4 10

Sample Output

8

题意:一共n个城市之间有n-1条边相连,每条边有个权值,表示从u到v或者从v到u,需要花费的钱,

每个城市有一个价值,表示在该城市买书(卖书)花费(赚取)的钱。

求如何买卖书,使得赚取的利润最大。

思路:设置一个虚拟起点和虚拟终点,每个点与起点间一条负边,值为这个点书的价值的相反数(代表买书花钱),每个点与终点连一条正边,值为这个点的书的价格(代表卖书赚钱)。然后按照图中给的边建无向边,权值为负(代表路费)。然后就是跑最长路,spfa改一下松弛条件就行

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 100005;
struct node{
	int v,w;
	int next;
}edge[N*4];
int id,head[N];
int n,vis[N],dis[N];
int val[N];
void init(){
	id=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v,int w){
	edge[id].v=v;
	edge[id].w=w;
	edge[id].next=head[u];
	head[u]=id++;
}
void SPFA(){
	queue<int>p;
	memset(vis,0,sizeof(vis));
	memset(dis,-Inf,sizeof(dis));
	vis[0]=1;
	dis[0]=0;
	p.push(0);
	while(!p.empty()){
		int u=p.front();
		p.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].v;
			int w=edge[i].w;
			if(dis[v]<dis[u]+w){
				dis[v]=dis[u]+w;
				if(!vis[v]){
					vis[v]=1;
					p.push(v);
				}
			}
		}
	}
	printf("%d\n",dis[n+1]);
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		init();
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			int x;
			scanf("%d",&x);
			add(0,i,-x);
			add(i,1+n,x);
		}
		for(int i=1;i<n;i++){
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			add(u,v,-w);
			add(v,u,-w);
		}
		SPFA();
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值