PAT(A) - 1078 Hashing(25)

1078 Hashing(25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

大致题意为:输入一些数,让他们哈希到哈希表中,输出各个数在哈希表中的地址。

分析:据题意可以把该题目分为以下两个步骤:

  • 输入的第一个数字为用户定义的hash表的长度,需要找到大于它的最小的质数。

  • 将数字哈希,由题目“Quadratic probing ”给出哈希冲突解决方式(本题坑点,多看点英语原版书吧),为二次再散列,公式为:

    addr=(h(key)+ii)%len  (0<=i<len) a d d r = ( h ( k e y ) + i ∗ i ) % l e n     ( 0 <= i < l e n )

#include <iostream>  
#include <algorithm> 
using namespace std;

bool isPrime(int x) {
    if (x == 1) return false;
    if (x == 2 || x == 3) return true;
    for (int i = 2; i*i <= x; i++) {
        if (x%i == 0)
            return false;
    }
    return true;
}
bool mark[10000];
int main() {
    int m, n, x, i;
    cin >> m >> n;
    memset(mark, false, sizeof(mark));
    while (isPrime(m) == false) m++;
    while (n--) {
        cin >> x;
        for (i = 0; i < m; i++) {
            if (mark[(x + i*i) % m] == false) {
                cout << (x + i*i) % m << (n ? " " : "\n");
                mark[(x + i*i) % m] = true;
                break;
            }
        }
        if (i == m)
            cout << "-" << (n ? " " : "\n");
    }
    return 0;
}

参考:https://blog.csdn.net/xtzmm1215/article/details/38390721

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值