ZOJ 1382 A Simple Task

A Simple Task

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.


Example

For n = 24, o = 3 and p = 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.


Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.


Output


The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.


Sample Input

1
24


Sample Output

3 3


题意:输入1个数n找到o,p使n = o2^p成立

注意:若用2个 for循环从小到大遍历的话,会超时

代码:

#include <stdio.h>
#include <math.h>


int main()
{
    int d;
    int n;
    scanf("%d",&d);
    getchar();
    while(d--){
        int o,p,j;
        scanf("%d",&n);
        for(j=0;;j++)
        {
            if(n%2==0)
                n=n/2;
            else
                break;
        }
        p=j;
        o=n;
        printf("%d %d\n",o,p);
    }
    return 0;
            
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值