POJ 1631 Bridging signals LIS(最长递增子序列) +nlogn算法+二分查找

本题就是求最长递增子序列的长度,用动态规划
Bridging signals
Time Limit:1000MS Memory Limit:10000K



Description

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4
这是刚刚开始写的O(N^2)算法,提交后TLE
/* Author yan
 *POJ 1631
 *Bridging signals
*/
#include<stdio.h>
int opt[40000];
int n;
int value[40000];

int main()
{
	int i,j;
	int test_case;
	int max;
	freopen("input","r",stdin);
	scanf("%d",&test_case);
	while(test_case--)
	{
		scanf("%d",&n);
		memset(opt,0,sizeof(opt));
		max=-1;
		for(i=0;i<n;i++) scanf("%d",&value[i]);
		for(i=0;i<n;i++)
		{
			opt[i]=1;
			for(j=0;j<i;j++)
			{
				if(value[i]>value[j]&&opt[i]<opt[j]+1) opt[i]=opt[j]+1;
			}
			if(max<opt[i]) max=opt[i];
		}
		printf("%d/n",max);
	}
	return 0;
}
看到网上的的优化,时间复杂度优化成O(N*logN)

/* Author yan *POJ 1631 *Bridging signals */ #include<stdio.h> #define MAX 40000 int n; int value[MAX];///记录原始数组 int opt[MAX+1];///记录长度为k的最长递增序列的结尾元素,下标从1开始 //int len[MAX];///记录以value[k]结尾的最长递增子序列的长度 int LIS(const int value[],const int n) { int i,j; int size=1; opt[1]=value[0]; //len[0]=1; for(i=1;i<n;i++) { if(value[i]<=opt[1]) j=1;//<=换为< else if(value[i]>opt[size]) j=++size;// > 换为: >= else j=binary_search(opt,size,value[i]); //printf("j=%d/n",j); opt[j]=value[i]; //len[i]=j; } return size; } int binary_search(const int opt[],const int size,const int value) { int left=1; int right=size; int mid; while(left<=right) { mid=(left+right)/2; if(value==opt[mid]) return mid; else if(value>opt[mid] && value<=opt[mid+1]) return mid+1;// >&&<= 换为: >= && < else if(value<opt[mid]) right=mid-1; else left=mid+1; } } int main() { int i,j; int test_case; int max; //freopen("input","r",stdin); scanf("%d",&test_case); while(test_case--) { scanf("%d",&n); //memset(opt,0,sizeof(opt)); for(i=0;i<n;i++) scanf("%d",&value[i]); printf("%d/n",LIS(value,n)); } return 0; }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值