UVa 369 Combinations (用double算组合数)

369 - Combinations

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=305

Computing the exact number of ways thatNthings can be takenMat a time can be a great challenge whenNand/orMbecome very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:

GIVEN:

displaymath41

Compute theEXACTvalue of:

displaymath43

You may assume that the final value ofCwill fit in a 32-bit Pascal LongInt or a C long.

For the record, the exact value of 100! is:

     93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621,
        468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253,
        697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000

Input and Output

The input to this program will be one or more lines each containing zero or more leading spaces, a value forN, one or more spaces, and a value forM. The last line of the input file will contain a dummyN,Mpair with both values equal to zero. Your program should terminate when this line is read.

The output from this program should be in the form:

Nthings takenMat a time isCexactly.

Sample Input

     100  6
      20  5
      18  6
       0  0

Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.

注意这句话:

You may assume that the final value ofCwill fit in a 32-bit Pascal LongInt or a C long.


完整代码:

/*0.022s*/

#include<cstdio>

int main()
{
	int N, M, i;
	double C;
	while (scanf("%d%d", &N, &M), N)
	{
		C = 1.0;
		for (i = N; i > N - M; --i) C *= (double)i;
		for (i = 2; i <= M; ++i) C /= (double)i;
		printf("%d things taken %d at a time is %.0f exactly.\n", N, M, C);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值