PAT 1019. General Palindromic Number (20)

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

#include<stdio.h>
int main(){
	long long n, b;
	int a[1000];
	scanf("%Ld%Ld\n", &n,&b);
	int index = 0;
	while(n != 0){
		a[index++] = n%b;
		n /= b;
	}
	int i = 0;
	int j = index - 1;
	int flag = 0;
	while(i<j){
		if(a[i] != a[j]){
			flag = 1;
			break;
		}
		i++;
		j--;
	}
	if(flag)
		printf("No\n");
	else
		printf("Yes\n");
	for(i =index-1; i> 0; i--){
		printf("%d ", a[i]);
	}
	printf("%d\n", a[0]);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值