【PAT】1019.General Palindromic Number (20)

题目描述

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

翻译:一个数字如果从前往后和从后往前写都相同的话那么这个数字就叫做回文数。例如,1234321是一个回文数。所有单个数字都是回文数。

INPUT FORMAT

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

翻译:每个输入文件包含一组测试数据。每组测试数据包含两个非负整数N和b,N是十进制数(0<=N<=10^9),b是基数(2<=b<=10^9),数字之间用空格隔开。

OUTPUT FORMAT

For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.

翻译:对于每个输入文件,首先输出一个“Yes”如果N是一个b进制的回文数,否则输出“No”。接下来一行以 “ak ak-1 … a0”.的格式输出N的b进制数。注意输出末尾不能有多余的空格。


Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1


Sample Input 2:

121 5

Sample Output 2:

No
4 4 1


解题思路

注意0的时候特殊处理。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,b,Judge[40],ccount=0;
int fun(){
    while(N){
        Judge[ccount++]=N%b;
        N/=b;
    }
    for(int i=0;i<ccount/2;i++){
        if(Judge[i]!=Judge[ccount-1-i])return 0;
    }
    return 1;
}
int main(){
    scanf("%d%d",&N,&b);
    if(fun())printf("Yes\n");
    else printf("No\n");
    for(int i=ccount-1;i>=0;i--){
        if(i==ccount-1)printf("%d",Judge[i]);
        else printf(" %d",Judge[i]);    
    }
    if(ccount==0)printf("0");
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值