POJ 1308 Is it a tree??

Is It A Tree?
Time Limit:1000MS Memory Limit:10000K
Total Submissions:9821 Accepted:3354

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
///
#include<stdio.h>
#include<stdlib.h>
/*
在定义c函数中使用了
bool strToInt()
结果报错
test9.c:4: error: expected '=', ',', ';', 'asm' or '__attribute__' before ‘strToInt'
后来知道
关键字bool是C++内置对布尔类型的支持。
C语言直到C99标准才增加了对布尔类型的支持,关键字为_Bool,因为bool已经被C++用了。

因此可以在程序中使用宏定义方式实现
#define bool _Bool
#define	true	  1
#define	false  0
*/
#define bool _Bool
#define	true	1
#define	false	0
#define Max 100

int parent[Max];
bool flag[Max];
/*
并查集操作
*/
void make_set(){
    int x;
    for(x = 1; x < Max; x ++){
        parent[x] = x;
        flag[x] = false;
    }
}

int find_set(int x){
    if(x != parent[x])
        parent[x] = find_set(parent[x]);//路径压缩
    return parent[x];
}

void union_set(int x, int y){
    x = find_set(x);
    y = find_set(y);
    if(x == y) return;
    parent[y] = x;
}

int main(){
    int x, y, t = 1, fir;
    while(scanf("%d %d", &x, &y) != EOF)
    {
        if(x == -1 && y == -1) break;//循环结束
        if(x == 0 && y == 0){//空树也是树,死人也是人
            printf("Case %d is a tree./n", t ++);
            continue;
/*其作用是:结束本次循环,即跳过循环体下面尚未执行的语句,接着进行下一次是否执行
循环的判断,(就是执行到continue时,立即结束本次循环,重新去判断循环条件是否为真)
*/
        }
        make_set();//初始化
        flag[x] = flag[y] = true;
        fir = x;
        bool tree = true;
        if(x == y) tree = false;//如果存在自己指向自己的节点,不是树
        else union_set(x, y);//否则 将x y合并
        while(scanf("%d %d", &x, &y) && x != 0)
	{
            flag[x] = flag[y] = true;
            if(find_set(x) == find_set(y)) tree = false;
            union_set(x, y);
        }
        for(x = 1; x < Max; x ++)
            if(flag[x] && find_set(x) != find_set(fir))//循环判断所有节点是否在一个连通子集,如果不是,则,不是树
                tree = false;
        if(tree) printf("Case %d is a tree./n", t ++);
        else printf("Case %d is not a tree./n", t ++);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值