并查集之POJ--1308--Is It A Tree?


Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34308 Accepted: 11630

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
 
貌似可以用多种方法解,然而菜鸡知识尚浅,只能用暑假学的并查集给水过去了/(ㄒoㄒ)/~~-------
并查集通俗的说就是不相交的数据结构!本题只需在合并数据之前判断下两个节点是否有同一个祖先,如果有同一祖先,说明两节点
之间已有一条路径,那么这就不是一棵“Tree”!最后遍历原数组是否有且只有一个集合即可。附代码:
 
#include<stdio.h>
#include<string.h>
int f[1000001];
struct ss
{
    int xx,yy;
}s[1000001];
int B(int z)
{
    if(f[z]==z)
        return z;
    else
    {
        f[z]=B(f[z]);
        return f[z];
    }
}
void A(int x1,int y1)
{
   int t1=B(x1);
   int t2=B(y1);
   if(t1!=t2)
    f[t2]=t1;
}
int main()
{
    int q=1;
    while(true)
    {
        int x,y;
        int p=0,max1=0;
        memset(f,0,sizeof(f));
    while(scanf("%d%d",&x,&y)!=EOF)
    {
        if(x==-1&&y==-1)
           return 0;
       else if(x==0&&y==0)
            break;
       else
       {
           s[p].xx=x;
           s[p].yy=y;
           f[x]=x;
           f[y]=y;//这里只需初始化出现的数据
           if(x>max1)
            max1=x;
           if(y>max1)
            max1=y;
            p++;
       }
    }
    int t=0;
    for(int i=0;i<p;i++)
    {
        if(B(s[i].xx)==B(s[i].yy))
        {
            t=1;
            break;
        }
        else
            A(s[i].xx,s[i].yy);
    }
    int sum=0;
    for(int i=1;i<=max1;i++)
        if(f[i]==i)
            sum++;
    if(p==0)
          printf("Case %d is a tree.\n",q);
    else if(sum==1&&t==0)
    printf("Case %d is a tree.\n",q);
    else
    printf("Case %d is not a tree.\n",q);
    q++;
    }
    return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值