POJ 1308 Is It A Tree?

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17523 Accepted: 6005

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

 

 

题意:给出一系列的点,前者指向后者,求是否是一棵树。

思路:并查集思想,主要注意以下几组数据

1: 0 0 空树是一棵树 
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树....自己开始一直在这么WA 好郁闷 重复都不行呀~~5555
4: 1 2 2 3 4 5 0 0 不是树 森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1 注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9-->1 错 
6: 1 2 2 1 0 0 也是错误的


#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=10010;

int father[N],b[N];
int flag;

int findSet(int x){
    if(x!=father[x]){
        father[x]=findSet(father[x]);
    }
    return father[x];
}

void Union(int a,int b){
    if(b!=father[b]){   //如果结点编号不等于本身,说明有两条边指向它
        flag=0;
        return ;
    }
    int x=findSet(a);
    int y=findSet(b);
    if(x==y){    //两个点的根结点相等 说明形成了环或本身指向本身
        flag=0;
        return ;
    }else
        father[y]=x;
}

int main(){

    //freopen("input.txt","r",stdin);

    int x,y;
    int cases=0;
    while(1){
        flag=1;
        int cnt=0;
        for(int i=0;i<N;i++)
            father[i]=i;
        scanf("%d%d",&x,&y);
        if(x==-1 && y==-1)
            break;
        if(x==0 && y==0){    //只有根结点
            printf("Case %d is a tree.\n",++cases);
            continue;
        }
        b[cnt++]=x;  //b数组存储 后面用来查找是否会形成森林
        b[cnt++]=y;
        Union(x,y);
        while(1){
            scanf("%d%d",&x,&y);
            if(x==0 && y==0)
                break;
            b[cnt++]=x;
            b[cnt++]=y;
            Union(x,y);
        }
        for(int i=0;i<cnt-1;i++)
            if(findSet(b[i])!=findSet(b[i+1])){
                flag=0;
                break;
            }
        if(flag)
            printf("Case %d is a tree.\n",++cases);
        else
            printf("Case %d is not a tree.\n",++cases);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值