题目如下:
描述 Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit-
输入
- The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A. 输出
- For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A. 样例输入
-
3 11 1001110110 101 110010010010001 1010 110100010101011
样例输出
-
3 0 3
利用Java自带的substring(beginningindex,endindex)提取字符串B中的字串,利用match函数比较,若相同则计数加1.
代码如下:
package binarymatch;
import java.util.*;
public class Main {
public static void main(String[] args)
{
Scanner input = new Scanner(System.in);
int num = 0;
// System.out.println("输入num");
num = input.nextInt();
String[] A = new String[num];
String[] B = new String[num];
for(int index = 0; index < num ; index++)
{
// System.out.println("输入A");
A[index] = input.next();
// System.out.println("输入B");
B[index] = input.next();
}
for(int index = 0; index < num ; index++)
{
System.out.println(binary_string_match(A[index],B[index]));
}
}
public static int binary_string_match(String A, String B)
{
int ret = 0;
int lengtha = A.length();
int lengthb = B.length();
for(int index = 0; index < (lengthb-lengtha+1); index++)
{
String sub = new String();
sub = B.substring(index, index+lengtha);
if(sub.matches(A))
ret++;
}
return ret;
}
}