hdu Strange fuction二分法不具有单调性

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 80Accepted Submission(s): 62

Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)


Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input
 
  
2 100 200
我自己没做

Sample Output
 
  
-74.4291 -178.8534
#include <iostream>
using namespace std;

double POW(double x,int n)
{
int i;
double sum=1.0;
for(i=1;i<=n;i++)
sum*=x;
return sum;
}
double find(double x,double y)
{
return 6*POW(x,7)+8*POW(x,6)+7*POW(x,3)+5*POW(x,2)-y*x ;
}

double find1(double x)
{
return 42*POW(x,6)+48*POW(x,5)+21*POW(x,2)+10*x;
}
int main()
{
int t;
double y,f,l,mid;
scanf("%d",&t);
while(t--)
{
scanf("%lf",&y);
f=0;
l=100;
if(find1(f)-y>=0)
{
printf("%.4lf/n",find(f,y));
continue;
}
else if(find1(l)-y<=0)
{
printf("%.4lf/n",find(l,y));
continue;
}
while(l-f>1e-6)
{
mid=(f+l)/2;
if(find1(mid)-y>=0)
l=mid;
else
f=mid;
}
printf("%.4lf/n",find((f+l)/2,y));
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值