Strange fuction(hdu 2899)

Strange fuction

TimeLimit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K(Java/Others)
Total Submission(s): 767 Accepted Submission(s):588


Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x<=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains aninteger T(1<=T<=100) which means thenumber of test cases. Then T lines follow, each line has only onereal numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4decimal places),when x is between 0 and 100.

Sample Input
2 100200

Sample Output
-74.4291-178.8534

Author
Redow

Recommend
lcy
单纯二分查找的题目
#include<math.h>    
#include <stdio.h>    
#include <stdlib.h>    
#include <string.h>  
using namespace std;
double g(double x)
{
     return42.0*pow(x,6.0)+48.0*pow(x,5.0)+21.0*pow(x,2.0)+10.0*x;
}
double f(double x,double y)
{
     return6.0*pow(x,7.0)+8.0*pow(x,6.0)+7.0*pow(x,3.0)+5.0*pow(x,2.0)-x*y;
}
int main(){
    int t;
    doubley,l,h,mid;
   scanf("%d",&t);
   while(t--){
       scanf("%lf",&y);
       if(g(100.0)-y<=0){
           printf("%.4lf",f(100.0,y));
           printf("1\n");
       }
       if(g(0.0)-y>=0){
           printf("%.4lf",f(0.0,y));
           continue;
       }
       l=0.0;
       h=100.0;
       while(h-l>1e-8){
           mid=(h + l)/2.0;
           if(g(mid)-y<0)
              l=mid;
           else
              h=mid;
       }
       printf("%.4lf\n",f(mid,y));
    }
    return0;
}
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值