HDU 1066 Last non-zero Digit in N!

Problem Description
The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,
N N!
0 1
1 1
2 2
3 6
4 24
5 120
10 3628800

For this problem, you are to write a program that can compute the last non-zero digit of the factorial for N. For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120.
Input
Input to the program is a series of nonnegative integers, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.
Output
For each integer input, the program should print exactly one line of output containing the single last non-zero digit of N!.
Sample Input
1 
2 
26 
125 
3125 
9999
Sample Output
1
2
4
8
2
8
题目意思:求N!的最后一位非零数字,例如:9!=362880,这时你应该输出8.
开始没有看清楚题目,不知道N有多大,WA了N道,后来才知道N可以非常大,不是我能解决的范围了,然后再一看吉大ACM模板,有这个模板,我就照着输了。先把最后所有的0去掉,方法就是在乘的时候统计因子2的个数,然后每遇到一个5,就去掉一个,那么乘出来就没有最后的0了~然后在乘的时候只保留最后一位就可以了,最后把统计了的2的个数乘回去(在统计的时候把2给提出来,这样就可以避免模的除法了!)
LANGUAGE:C
CODE:
#include<stdio.h>
#include<string.h>

#define maxn 10001

int lastdigit(char buf[])
{
	const int mod[20]={1,1,2,6,4,2,2,4,2,8,4,4,8,4,6,8,8,6,8,2};
	int len=strlen(buf),a[maxn],i,c,ret=1;
	if(len==1)return mod[buf[0]-'0'];
	for(i=0;i<len;i++)
		a[i]=buf[len-1-i]-'0';
	while(len)
	{
		ret=ret*mod[a[1]%2*10+a[0]]%5;
		for(c=0,i=len-1;i>=0;i--)
		{
			c=c*10+a[i],a[i]=c/5,c%=5;
		}
		len-=!a[len-1];
	}
	return ret+ret%2*5;
}

int main()
{
	char  n[maxn];
	while(scanf("%s",n)!=EOF)
	{
		printf("%d\n",lastdigit(n));
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值