Milking Time(DP)

Milking Time
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 4283  Accepted: 1775

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

 

       题意:

       给出 N,M,R,代表总共时长为 N ,有 M 个容器,每个容器需要间隔 R 的时间才能用下一个。需要给牛喂奶,后给出 M 个容器的使用时间 S(起时),E(终时)与 产量 W。要如何安排时间使最后产量达到最大。

 

       思路:

       DP。先将时间以结束时间由小到大排序一遍。dp [ i ] 代表选择第 i 个容器时可以获得的最大产量。所以 dp [ i ] = max (dp [ j ] + cow [ i ].val,dp [ i ] )( j <= i && cow[ j ].End + r <= cow [ i ].Sta )。最后还要算出所有容器 dp 出来的最大值才是答案。初始化时,每个 dp 对应为自身的 val 值,所以 dp [ i ] 代表一定会选择自己本身的这个容器。

       

       为什么要由小到大排序?

       因为要最大利用时间,若不排序的话,那么根据判断条件 cow [ j ].End + r <= cow [ i ].Sta,要求的是上一个的结束时间 + 间隙 小于 要该容器的开始时间才能进行更新,不排序的话,那么有些容器就可能会跟新不到了。故要由小到大排序。

 

       AC:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int MAX = 1005;

typedef struct { int Sta, End, val; } node;

node cow[MAX];
int dp[MAX];

int cmp(node a, node b) { return a.End < b.End; }

int main () {
        int n, m ,r;
        scanf("%d%d%d", &n, &m, &r);

        for (int i = 0; i < m; ++i)
                scanf("%d%d%d", &cow[i].Sta, &cow[i].End, &cow[i].val);

        sort(cow, cow + m, cmp);
        for (int i = 0; i < m; ++i) dp[i] = cow[i].val;

        int max_num = 0;
        for (int i = 0; i < m; ++i) {
                for (int j = i + 1; j < m; ++j) {
                        if (cow[i].End + r <= cow[j].Sta)
                                dp[j] = max(dp[j], dp[i] + cow[j].val);
                }
                max_num = max(max_num, dp[i]);
        }

        printf("%d\n", max_num);

        return 0;
}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
最新发布
02-12
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值